Fix candidate selection on unknown package

Before this fix having dependency on unknown package with version or
repository limitation caused updater to fail on lua error. This fixes
that and adds small comment noting that we should remember that we might
depend on unknown package.
2 jobs for fix-unknown in 17 minutes and 58 seconds (queued for 2 seconds)
Status Job ID Name Coverage
  Test
passed #20850
test

00:17:58

passed #20851
test_busybox

00:17:58