Commit ec0fbe3e authored by Karel Koci's avatar Karel Koci 🤘

updater: add dependency on ca-certificates

From version 60.0.3 we are using system certificates and there is
possibility that user doesn't have them (because for some stupid reason
did opkg install --force-reinstall or upgrade ca-certificates which at
first removes ca-certificates and then tries to download new version
which fails. This ensures that updater when it's updating to new version
also installs ca-certificates before it if they are missing.
parent 4a4cc0b9
......@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=updater-ng
PKG_VERSION:=60.0.6
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater.git
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
......@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/host-build.mk
define Package/$(PKG_NAME)
TITLE:=The next generation updater
DEPENDS:=+liblua +libevent2 +usign +libcurl +vixie-cron
DEPENDS:=+liblua +libevent2 +usign +libcurl +vixie-cron +ca-certificates
endef
define Package/$(PKG_NAME)/install
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment