distro: add explicit dependency on new lua-cqueues

Older cqueues may cause some issues with lua-http
parent 73d660c5
......@@ -39,9 +39,10 @@ Replaces:
Breaks:
libkres9 (<< 3.2.1-2),
Recommends:
knot-resolver-module-http,
lua-basexx,
lua-cqueues,
Suggests:
knot-resolver-module-http,
Description: caching, DNSSEC-validating DNS resolver
The Knot Resolver is a caching full resolver implementation
written in C and LuaJIT, including both a resolver library and a
......@@ -66,6 +67,7 @@ Depends:
libjs-bootstrap,
libjs-d3,
libjs-jquery,
lua-cqueues (>= 20171014),
lua-http,
lua-mmdb,
systemd,
......
......@@ -119,9 +119,11 @@ Documentation for Knot Resolver
Summary: HTTP/2 module for Knot Resolver
Requires: knot-resolver
%if 0%{?fedora}
Requires: compat-lua-cqueues >= 20171014
Requires: compat-lua-http
Requires: compat-lua-mmdb
%else
Requires: lua-cqueues >= 20171014
Requires: lua-http
Requires: lua-mmdb
%endif
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment