Verified Commit c836c1ab authored by Karel Koci's avatar Karel Koci 🤘 Committed by Karel Koci

Drop updater.sh

This file was here for backward compatibility. It is long enough that
anyone should have already migrated away from it.
parent 9da06052
#!/bin/sh
SUPERVISOR_ARGS="--wait-for-network"
WIPE=true
for ARG in "$@"; do
if $WIPE; then
shift $#
WIPE=false
fi
case "$ARG" in
--rand-sleep)
SUPERVISOR_ARGS="$SUPERVISOR_ARGS --rand-sleep"
;;
-b|--background|-w|-n)
echo "Argument $ARG ignored." >&2
;;
*)
set "$@" "$ARG"
;;
esac
done
if [ -t 1 ] ; then
echo "updater.sh is obsoleted. Please use pkgupdate directly instead." >&2
if $BACKGROUND; then
pkgupdate --batch "$@" &
else
pkgupdate --batch "$@"
fi
else
if which updater-supervisor 2>/dev/null >&2; then
updater-supervisor -d
else
pkgupdate --batch &
fi
fi
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment