Commit c58e617d authored by Matyáš Latner's avatar Matyáš Latner

Project migrated to Java 8

parent 0f9b59ed
...@@ -21,7 +21,7 @@ final BUILD_CONFIG_DIR = "${buildDir}/generated/source/buildConfig/" ...@@ -21,7 +21,7 @@ final BUILD_CONFIG_DIR = "${buildDir}/generated/source/buildConfig/"
final BUILD_CONFIG_ENCODING = 'UTF-8' final BUILD_CONFIG_ENCODING = 'UTF-8'
android { android {
buildToolsVersion "20.0.0" buildToolsVersion "24.0.3"
compileSdkVersion 21 compileSdkVersion 21
packagingOptions { packagingOptions {
...@@ -34,11 +34,14 @@ android { ...@@ -34,11 +34,14 @@ android {
} }
defaultConfig { defaultConfig {
targetSdkVersion 17 targetSdkVersion 21
versionName tablexiaVersionName versionName tablexiaVersionName
versionCode tablexiaVersionCode versionCode tablexiaVersionCode
applicationId rootProject.applicationBaseId applicationId rootProject.applicationBaseId
testApplicationId rootProject.applicationBaseId + ".test" testApplicationId rootProject.applicationBaseId + ".test"
jackOptions {
enabled true
}
} }
buildTypes { buildTypes {
...@@ -116,8 +119,8 @@ android { ...@@ -116,8 +119,8 @@ android {
} }
} }
compileOptions { compileOptions {
sourceCompatibility JavaVersion.VERSION_1_6 sourceCompatibility JavaVersion.VERSION_1_8
targetCompatibility JavaVersion.VERSION_1_6 targetCompatibility JavaVersion.VERSION_1_8
} }
command { command {
......
...@@ -25,7 +25,7 @@ buildscript { ...@@ -25,7 +25,7 @@ buildscript {
jcenter { url "http://jcenter.bintray.com/" } jcenter { url "http://jcenter.bintray.com/" }
} }
dependencies { dependencies {
classpath 'com.android.tools.build:gradle:2.0.0' classpath 'com.android.tools.build:gradle:2.2.2'
classpath 'org.robovm:robovm-gradle-plugin:1.12.0' classpath 'org.robovm:robovm-gradle-plugin:1.12.0'
classpath 'com.github.JakeWharton:sdk-manager-plugin:220bf7a88a7072df3ed16dc8466fb144f2817070' classpath 'com.github.JakeWharton:sdk-manager-plugin:220bf7a88a7072df3ed16dc8466fb144f2817070'
classpath 'com.novoda:gradle-android-command-plugin:1.3.0' classpath 'com.novoda:gradle-android-command-plugin:1.3.0'
...@@ -369,7 +369,7 @@ project(":desktop") { ...@@ -369,7 +369,7 @@ project(":desktop") {
project(":android") { project(":android") {
apply plugin: 'android-sdk-manager' apply plugin: 'android-sdk-manager'
apply plugin: "android" apply plugin: 'com.android.application'
apply plugin: 'android-command' apply plugin: 'android-command'
configurations { natives } configurations { natives }
......
#Mon Apr 18 18:31:45 CEST 2016 #Fri Nov 25 11:07:23 CET 2016
distributionBase=GRADLE_USER_HOME distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.zip distributionUrl=https\://services.gradle.org/distributions/gradle-2.14.1-all.zip
...@@ -16,5 +16,5 @@ ...@@ -16,5 +16,5 @@
*/ */
task wrapper(type: Wrapper) { task wrapper(type: Wrapper) {
gradleVersion = '2.10' gradleVersion = '2.14.1'
} }
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment