Commit 694b81e3 authored by Tomas Krizek's avatar Tomas Krizek

respdiff: check minimal Python version

Closes #24
parent de6891db
......@@ -14,10 +14,10 @@ Installation
$ cd respdiff
$ pip3 install -r requirements.txt
Respdiff toolchain requires Python 3 (Python 3.4+ should work at the moment,
newer is better). There are also some Python package dependencies that are
listed in ``requirements.txt``. If you'd prefer to use your distribution
packages, please install them manually instead of using ``pip3``.
Respdiff toolchain requires **Python 3.5.2+**. There are also some Python package
dependencies that are listed in ``requirements.txt``. If you'd prefer to use
your distribution packages, please install them manually instead of using
``pip3``.
Usage
-----
......
......@@ -3,3 +3,6 @@ import sys
# LMDB isn't portable between LE/BE platforms
# upon import, check we're on a little endian platform
assert sys.byteorder == 'little', 'Big endian platforms are not supported'
# Check minimal Python version
assert sys.version_info >= (3, 5, 2), 'Minimal supported Python version is 3.5.2'
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment