rebrand to "Knot Resolver"

Let's see if it helps against confusion with "Knot DNS" authoritative
server or not.
24 jobs for <span class="ref-name">rebrand</span> in 24 seconds (queued for 4 seconds)
Status Job ID Name Coverage
  Build
failed #163304
docker linux amd64
build:clang:linux:amd64

00:00:16

failed #163303
docker linux amd64
build:linux:amd64

00:00:16

passed #163305
docker linux amd64 allowed to fail
srpm

00:00:23

 
  Test
skipped #163312
docker linux amd64
deckard:linux:amd64
skipped #163319
privileged
distro:epel-7
skipped #163318
privileged
distro:fedora-27
skipped #163311
docker
doc
skipped #163310
docker linux amd64
installcheck:linux:amd64
skipped #163313
docker linux amd64
installcheck:valgrind:linux:amd64
skipped #163307
docker
lint:c
skipped #163308
docker allowed to fail
lint:clang-scan-build
skipped #163306
docker
lint:lua
skipped #163316
docker linux amd64
respdiff:iter:tcp:linux:amd64
skipped #163317
docker linux amd64
respdiff:iter:tls:linux:amd64
skipped #163315
docker linux amd64
respdiff:iter:udp:linux:amd64
skipped #163309
docker linux amd64
test:linux:amd64
skipped #163314
docker linux amd64
test:linux:amd64:valgrind
 
  Respdiff
skipped #163320
respdiff
respdiff:fwd-tls6-kresd.udp6
skipped #163321
respdiff
respdiff:fwd-udp6-kresd.udp6
skipped #163325
respdiff
respdiff:fwd-udp6-unbound.tcp6
skipped #163326
respdiff
respdiff:fwd-udp6-unbound.tls6
skipped #163324
respdiff
respdiff:fwd-udp6-unbound.udp6
skipped #163323
respdiff allowed to fail
respdiff:iter.tls6
skipped #163322
respdiff
respdiff:iter.udp6
 
Name Stage Failure
failed
build:linux:amd64 Build
[yes] libedit (client)
[yes] libfstrm (modules/dnstap)
[no] libprotobuf-c (modules/dnstap)
[yes] proto-c (modules/dnstap)
[yes] lcov (code coverage)
[yes] luacov (code coverage)

Makefile:89: *** libknot >= 2.7.1 required. Stop.
ERROR: Job failed: exit code 1
failed
build:clang:linux:amd64 Build
[yes] libedit (client)
[yes] libfstrm (modules/dnstap)
[no] libprotobuf-c (modules/dnstap)
[yes] proto-c (modules/dnstap)
[yes] lcov (code coverage)
[yes] luacov (code coverage)

Makefile:132: *** libknot >= 2.7.1 required. Stop.
ERROR: Job failed: exit code 1