Verified Commit 7fed9690 authored by Petr Špaček's avatar Petr Špaček

Require libknot 2.6.4 to avoid mysterious problems with DNS-over-TLS.

Respdiff on kresd under load showed that DNS-over-TLS has higher ratio
of SERVFAILs than other transports. For some reason the problem
disappeared after upgrading from libknot 2.6.3 to 2.6.4, and appeared
again after downgrade.
parent 194e4752
Pipeline #33280 passed with stages
in 10 minutes and 15 seconds
......@@ -16,7 +16,7 @@ lint-lua: $(patsubst %.lua.in,%.lua,$(wildcard */*/*.lua.in))
.PHONY: all install check clean doc info lint
# Dependencies
KNOT_MINVER := 2.4.0
KNOT_MINVER := 2.6.4
$(eval $(call find_lib,libknot,$(KNOT_MINVER),yes))
$(eval $(call find_lib,libdnssec,$(KNOT_MINVER),yes))
$(eval $(call find_lib,libzscanner,$(KNOT_MINVER),yes))
......
......@@ -7,6 +7,7 @@ Incompatible changes
- systemd: more chages in default unit files (TODO)
- ta_sentinel: implement protocol draft-ietf-dnsop-kskroll-sentinel-01
(our draft-ietf-dnsop-kskroll-sentinel-00 implementation had inverted logic)
- libknot: require version 2.6.4 or newer to get bugfixes for DNS-over-TLS
Bugfixes
--------
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment