Commit 66b95f23 authored by Tomas Krizek's avatar Tomas Krizek

distro/rpm: reformat spec file

parent 27c2c7f3
......@@ -35,20 +35,26 @@ Source102: gpgkey-4A8BA48C2AED933BD495C509A1FBA5F7EF8C4869.gpg.asc
BuildRequires: gnupg2
%endif
BuildRequires: pkgconfig(cmocka)
BuildRequires: pkgconfig(hiredis)
BuildRequires: pkgconfig(libedit)
BuildRequires: pkgconfig(libknot) >= 2.6.4
BuildRequires: pkgconfig(libzscanner) >= 2.4.2
BuildRequires: pkgconfig(libdnssec) >= 2.3.1
BuildRequires: pkgconfig(libuv)
BuildRequires: pkgconfig(luajit) >= 2.0
BuildRequires: pkgconfig(libedit)
BuildRequires: pkgconfig(libmemcached) >= 1.0
BuildRequires: pkgconfig(hiredis)
BuildRequires: pkgconfig(libsystemd)
BuildRequires: pkgconfig(libuv)
BuildRequires: pkgconfig(luajit) >= 2.0
BuildRequires: pkgconfig(systemd)
BuildRequires: pkgconfig(cmocka)
BuildRequires: systemd
# Lua 5.1 version of the libraries have different package names
%if 0%{?rhel}
Requires: lua-socket
Requires: lua-sec
%else
Requires: lua-socket-compat
Requires: lua-sec-compat
%endif
%if 0%{?fedora}
# dependencies for doc package; disable in EPEL (missing fonts)
......@@ -59,15 +65,6 @@ BuildRequires: python2-sphinx
BuildRequires: python2-sphinx_rtd_theme
%endif
# Lua 5.1 version of the libraries have different package names
%if 0%{?rhel}
Requires: lua-socket
Requires: lua-sec
%else
Requires: lua-socket-compat
Requires: lua-sec-compat
%endif
Requires(pre): shadow-utils
Requires(post): systemd
Requires(preun): systemd
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment