migrate to Knot DNS 2.8

parent 1bbe50b4
......@@ -8,7 +8,7 @@ variables:
RESPDIFF_COUNT: 1
RESPDIFF_FORCE: 0
RESPERF_FORCE: 0
KNOT_VERSION: '2.7'
KNOT_VERSION: '2.8'
LIBKRES_ABI: 9
LIBKRES_NAME: libkres
MESON_TEST: meson test -C build_ci* -t 2 --print-errorlogs
......@@ -335,7 +335,7 @@ pytests:
-p $RESPDIFF_PRIORITY
-c $RESPDIFF_COUNT
$(sudo -u respdiff /var/opt/respdiff/contrib/job_manager/create.py
"$(git rev-parse --short HEAD)" -l $LABEL -t $RESPDIFF_TEST
"$(git rev-parse --short HEAD)" -l $LABEL -t $RESPDIFF_TEST --knot-branch=$KNOT_VERSION
--respdiff-stats /var/tmp/respdiff-jobs/ref_current/*_${RESPDIFF_TEST}_stats.json)
- for f in $TESTDIR/*.json; do test -s "$f" || (cat $TESTDIR/*stderr*; exit 1); done
- sudo -u respdiff /var/opt/respdiff/contrib/job_manager/plot_ref.sh $TESTDIR/.. /var/tmp/respdiff-jobs/ref_current $RESPDIFF_TEST
......
......@@ -19,7 +19,7 @@ matrix:
fast_finish: true
env:
global:
- KNOT_DNS_VERSION=2.7
- KNOT_DNS_VERSION=2.8
- MALLOC_CHECK_=3
- MALLOC_PERTURB_=223
before_script:
......
# Intermediate container for Knot DNS build (not persistent)
FROM debian:stable AS knot-dns-build
ARG KNOT_DNS_VERSION=v2.7.6
ARG KNOT_DNS_VERSION=v2.8.0
# Build dependencies
ENV KNOT_DNS_BUILD_DEPS git-core build-essential libtool autoconf pkg-config \
......
......@@ -10,6 +10,7 @@ Incompatible changes
- default modules dir location has changed
- DNSSEC is enabled by default
- upstream packages for Debian now require systemd
- libknot >= 2.8 is required
Improvements
------------
......
......@@ -4,7 +4,7 @@ Docker Build
* debian-buster
```
$ export KNOT_BRANCH=2.7
$ export KNOT_BRANCH=2.8
$ docker build -t registry.labs.nic.cz/knot/knot-resolver/ci/debian-buster:knot-$KNOT_BRANCH --build-arg KNOT_BRANCH=$KNOT_BRANCH debian-buster
$ docker login registry.labs.nic.cz
......
FROM debian:buster-20190204
FROM debian:buster-20190228
MAINTAINER Knot Resolver <knot-resolver@labs.nic.cz>
ARG KNOT_BRANCH=2.7
ARG KNOT_BRANCH=2.8
WORKDIR /root
CMD ["/bin/bash"]
......
......@@ -406,6 +406,7 @@ struct zs_scanner {
_Bool automatic;
void (*record)(zs_scanner_t *);
void (*error)(zs_scanner_t *);
void (*comment)(zs_scanner_t *);
void *data;
} process;
struct {
......
......@@ -14,7 +14,7 @@ install=install
depends=(
'dnssec-anchors'
'gnutls'
'knot>=2.7.6'
'knot>=2.8'
'libedit'
'libuv'
'lmdb'
......
......@@ -9,7 +9,7 @@ Build-Depends:
libcmocka-dev (>= 1.0.0),
libedit-dev,
libgnutls28-dev,
libknot-dev (>= 2.7.6),
libknot-dev (>= 2.8),
liblmdb-dev,
libluajit-5.1-dev,
libsystemd-dev (>= 227) [linux-any],
......
......@@ -40,9 +40,9 @@ BuildRequires: meson
BuildRequires: pkgconfig(cmocka)
BuildRequires: pkgconfig(gnutls)
BuildRequires: pkgconfig(libedit)
BuildRequires: pkgconfig(libknot) >= 2.7.6
BuildRequires: pkgconfig(libzscanner) >= 2.7.6
BuildRequires: pkgconfig(libdnssec) >= 2.7.6
BuildRequires: pkgconfig(libknot) >= 2.8
BuildRequires: pkgconfig(libzscanner) >= 2.8
BuildRequires: pkgconfig(libdnssec) >= 2.8
BuildRequires: pkgconfig(libsystemd)
BuildRequires: pkgconfig(libuv)
BuildRequires: pkgconfig(luajit) >= 2.0
......
......@@ -33,7 +33,7 @@ The following is a list of dependencies needed to build and run Knot Resolver.
"meson >= 0.46", "*all*", "*(build only)* [#]_"
"C and C++ compiler", "*all*", "*(build only)* [#]_"
"`pkg-config`_", "*all*", "*(build only)* [#]_"
"libknot_ 2.7.6+", "*all*", "Knot DNS libraries"
"libknot_ 2.8+", "*all*", "Knot DNS libraries"
"LuaJIT_ 2.0+", "*all*", "Embedded scripting language."
"libuv_ 1.7+", "*all*", "Multiplatform I/O and services."
"lmdb", "*all*", "Memory-mapped database for cache"
......
......@@ -9,7 +9,7 @@ project(
message('--- required dependencies ---')
knot_version = '>=2.7.6'
knot_version = '>=2.8'
libknot = dependency('libknot', version: knot_version)
libdnssec = dependency('libdnssec', version: knot_version)
libzscanner = dependency('libzscanner', version: knot_version)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment