Commit f17a5f9a authored by Daniel Salzman's avatar Daniel Salzman

distro: add libmaxminddb dependency

parent c6be7687
......@@ -12,9 +12,17 @@ pkgdesc="High-performance authoritative-only DNS server"
arch=('x86_64')
url="https://www.knot-dns.cz/"
license=('GPL3')
depends=('lmdb' 'liburcu' 'protobuf-c' 'fstrm' 'libedit' 'systemd' 'libcap-ng' 'gnutls' 'libidn2')
depends=('fstrm'
'gnutls'
'libcap-ng'
'libedit'
'libidn2'
'libmaxminddb'
'liburcu'
'lmdb'
'protobuf-c'
'systemd')
backup=('etc/knot/knot.conf')
source=("${pkgname}_${pkgver}.orig.tar.xz"
"${pkgname}.service"
"${pkgname}.sysusers"
......
......@@ -20,6 +20,7 @@ Build-Depends:
libgnutls28-dev,
libidn11-dev,
liblmdb-dev,
libmaxminddb-dev,
libprotobuf-c-dev,
libsystemd-dev [linux-any] | libsystemd-daemon-dev [linux-any],
libsystemd-dev [linux-any] | libsystemd-journal-dev [linux-any],
......
......@@ -33,10 +33,11 @@ BuildRequires: pkgconfig(libedit)
# Optional dependencies
BuildRequires: pkgconfig(libcap-ng)
BuildRequires: pkgconfig(libidn2)
BuildRequires: pkgconfig(libsystemd)
BuildRequires: pkgconfig(libfstrm)
BuildRequires: pkgconfig(libidn2)
BuildRequires: pkgconfig(libmaxminddb)
BuildRequires: pkgconfig(libprotobuf-c)
BuildRequires: pkgconfig(libsystemd)
BuildRequires: pkgconfig(systemd)
# Distro-dependent dependencies
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment