Commit dbe6c595 authored by Jan Včelák's avatar Jan Včelák 🚀

doc: update compilation dependencies

parent c9521a66
......@@ -66,6 +66,10 @@ Install optional packages to override embedded libraries:
Install optional packages:
# yum install libcap-ng-devel systemd-devel libidn-devel protobuf-c-devel fstrm-devel
When compiling on RHEL based system, the Fedora EPEL repository has to be
enabled. Also for RHEL 6, forward compatibility package gnutls30-devel
with newer GnuTLS is required instead of gnutls-devel.
2) Install Knot DNS
Knot DNS requires compiler to support atomic intrinsics.
......
......@@ -31,7 +31,7 @@ Required libraries
Knot DNS requires few libraries to be compiled:
* GnuTLS, at least 3.0
* GnuTLS, at least 3.3
* Jansson, at least 2.3
* Userspace RCU, at least 0.5.4
* libedit
......@@ -39,6 +39,7 @@ Knot DNS requires few libraries to be compiled:
* libcap-ng, at least 0.6.4 (optional)
* libidn (optional)
* libsystemd (optional)
* protobuf-c and fstrm (optional)
The LMDB library is required. It is included with the Knot DNS source code,
however linking with the system library is preferred.
......@@ -53,6 +54,9 @@ support in Knot DNS utilities.
If the libsystemd library is available, the server will use systemd's startup
notifications mechanism and journald for logging.
If the protobuf-c and fstrm libraries are available, the support for logging
in Dnstap format will be included.
.. _Installation from source code:
Installation from source code
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment