Commit 9aee0e4d authored by Ondřej Surý's avatar Ondřej Surý

Add support for detecting ED25519 support in GnuTLS

parent 7b916703
......@@ -113,20 +113,20 @@ AM_CONDITIONAL([FAST_PARSER], [test "$enable_fastparser" = "yes"])
# GnuTLS crypto backend
PKG_CHECK_MODULES([gnutls], [gnutls >= 3.3 nettle], [
save_CFLAGS=$CFLAGS
save_LIBS=$LIBS
CFLAGS="$CFLAGS $gnutls_CFLAGS"
LIBS="$LIBS $gnutls_LIBS"
AC_CHECK_HEADERS([nettle/version.h])
CFLAGS=$save_CFLAGS
save_LIBS=$LIBS
LIBS="$LIBS $gnutls_LIBS"
AC_CHECK_FUNC([gnutls_pkcs11_copy_pubkey], [enable_pkcs11=yes], [enable_pkcs11=no])
AS_IF([test "$enable_pkcs11" = yes],
[AC_DEFINE([ENABLE_PKCS11], [1], [PKCS #11 support available])])
AC_CHECK_DEFINE([$gnutls_CFLAGS], [GNUTLS_PK_EDDSA_ED25519], [enable_ed25519=yes], [enable_ed25519=no])
AC_CHECK_DECL([GNUTLS_PK_EDDSA_ED25519], [enable_ed25519=yes], [enable_ed25519=no], [#include <gnutls/gnutls.h>])
AS_IF([test "$enable_ed25519" = yes],
[AC_DEFINE([HAVE_ED25519], [1], [GnuTLS ED25519 support available])])
CFLAGS=$save_CFLAGS
LIBS=$save_LIBS
])
......@@ -569,6 +569,7 @@ result_msg_base=" $PACKAGE $VERSION
Utilities with Dnstap: ${opt_dnstap}
Systemd integration: ${enable_systemd}
PKCS #11 support: ${enable_pkcs11}
ED25519 support: ${enable_ed25519}
Code coverage: ${enable_code_coverage}
Sanitizer: ${with_sanitize}
LibFuzzer: ${libfuzzer_LIBS}"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment