Commit 72e17a2d authored by Daniel Salzman's avatar Daniel Salzman

doc: update optional dependencies

parent 07715aa0
......@@ -61,8 +61,8 @@ Required libraries
Knot DNS requires a few libraries to be available:
* libedit
* GnuTLS >= 3.3
* Userspace RCU >= 0.5.4
* gnutls >= 3.3
* liburcu >= 0.5.4
* lmdb >= 0.9.15
.. NOTE::
......@@ -72,19 +72,20 @@ Knot DNS requires a few libraries to be available:
Optional libraries
==================
International Domain Names support (IDNA2003 or IDNA2008) in kdig needs:
International Domain Names support (IDNA2008 or IDNA2003) in **kdig**:
* libidn or libidn2
* libidn2 (or libidn)
Systemd's startup notifications mechanism and journald logging need:
Systemd's startup notification mechanism and journald logging:
* libsystemd
Dnstap support in kdig and module dnstap need:
Dnstap support in **kdig** or module :ref:`dnstap<mod-dnstap>`:
* fstrm (and protobuf-c if building from source code)
POSIX 1003.1e :manpage:`capabilites(7)` by sandboxing exposed threads.
Most rights are stripped from the exposed threads for security reasons.
Linux :manpage:`capabilities(7)` support, which allows the server to be started
as a non-root user/group, binding to privileged ports (53), and giving up all
its capabilities, resulting in a completely unprivileged process:
* libcap-ng >= 0.6.4
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment