Commit 215ce4fb authored by Petr Špaček's avatar Petr Špaček

Deckard: Use default Python version from system

Linux distributions are moving towards Python 3. As a consequence,
staying on Python 2 is causing problems. E.g. Deckard errored out
on missing 'dns' package but 'pip install' claimed that 'dns' is already
installed...

From now the Deckard is using default Python version so it should be
less surprising. If necessary, the default version can be overriden
using PYTHON variable in Makefile.

An important side-effect is that Deckard running under Python 3 is
easier to debug because Python 3 is able to report whole chains
of exceptions properly.
parent 0ee41b14
......@@ -4,7 +4,7 @@ DAEMON ?= kresd
TEMPLATE ?= template/kresd.j2
CONFIG ?= config
PYTHON := python3
PYTHON ?= python
LIBEXT := .so
PLATFORM := $(shell uname -s)
ifeq ($(PLATFORM),Darwin)
......
#!/usr/bin/env python3
#!/usr/bin/env python
from __future__ import print_function
import sys
......
#!/usr/bin/env python2
#!/usr/bin/env python
import sys
from distutils.core import setup
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment