Commit cee543a0 authored by Tomas Krizek's avatar Tomas Krizek

meson: update dependencies

parent 1b694725
......@@ -18,7 +18,7 @@ matrix:
fast_finish: true
env:
global:
- KNOT_DNS_VERSION=v2.7.2
- KNOT_DNS_VERSION=v2.7.6
- DYLD_LIBRARY_PATH="${HOME}/.local/lib"
- MALLOC_CHECK_=3
- MALLOC_PERTURB_=223
......
# Intermediate container for Knot DNS build (not persistent)
FROM debian:stable AS knot-dns-build
ARG KNOT_DNS_VERSION=v2.7.2
ARG KNOT_DNS_VERSION=v2.7.6
# Build dependencies
ENV KNOT_DNS_BUILD_DEPS git-core build-essential libtool autoconf pkg-config \
......
......@@ -18,7 +18,7 @@ lint-lua: $(patsubst %.lua.in,%.lua,$(wildcard */*/*.lua.in))
.PHONY: all install check clean doc info lint
# Dependencies
KNOT_MINVER := 2.7.2
KNOT_MINVER := 2.7.6
$(eval $(call find_lib,libknot,$(KNOT_MINVER),yes))
$(eval $(call find_lib,libdnssec,$(KNOT_MINVER),yes))
$(eval $(call find_lib,libzscanner,$(KNOT_MINVER),yes))
......
Knot Resolver 3.x.y (2019-0m-dd)
================================
Incompatible changes
--------------------
- libknot >= 2.7.6 is required
Improvements
------------
- policy.TLS_FORWARD: if hostname is configured, send it on wire (!759)
......
......@@ -14,7 +14,7 @@ install=install
depends=('cmocka'
'dnssec-anchors'
'gnutls'
'knot>=2.7.2'
'knot>=2.7.6'
'libedit'
'libsystemd'
'libuv'
......
......@@ -16,7 +16,7 @@ Build-Depends:
libedit-dev,
libgeoip-dev,
libgnutls28-dev,
libknot-dev (>= 2.7.2),
libknot-dev (>= 2.7.6),
liblmdb-dev,
libluajit-5.1-dev,
libsystemd-dev (>= 227) [linux-any],
......
......@@ -38,9 +38,9 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig(cmocka)
BuildRequires: pkgconfig(gnutls)
BuildRequires: pkgconfig(libedit)
BuildRequires: pkgconfig(libknot) >= 2.7.2
BuildRequires: pkgconfig(libzscanner) >= 2.7.2
BuildRequires: pkgconfig(libdnssec) >= 2.7.2
BuildRequires: pkgconfig(libknot) >= 2.7.6
BuildRequires: pkgconfig(libzscanner) >= 2.7.6
BuildRequires: pkgconfig(libdnssec) >= 2.7.6
BuildRequires: pkgconfig(libsystemd)
BuildRequires: pkgconfig(libuv)
BuildRequires: pkgconfig(luajit) >= 2.0
......
......@@ -36,10 +36,11 @@ The following is a list of software required to build Knot Resolver from sources
"C and C++ compiler", "*all*", "*(build only)* [#]_"
"`pkg-config`_", "*all*", "*(build only)* [#]_"
"hexdump or xxd", "``daemon``", "*(build only)*"
"libknot_ 2.7.2+", "*all*", "Knot DNS libraries - requires autotools, GnuTLS, ..."
"libknot_ 2.7.6+", "*all*", "Knot DNS libraries"
"LuaJIT_ 2.0+", "``daemon``", "Embedded scripting language."
"libuv_ 1.7+", "``daemon``", "Multiplatform I/O and services (libuv_ 1.0 with limitations [#]_)."
"lmdb", "``daemon``", "If missing, a static version is embedded."
"libuv_ 1.7+", "*all*", "Multiplatform I/O and services."
"lmdb", "*all*", ""
"GnuTLS", "*all*", ""
There are also *optional* packages that enable specific functionality in Knot Resolver, they are useful mainly for developers to build documentation and tests.
......
......@@ -64,7 +64,6 @@ libkres_lib = library('kres',
dependencies: [
contrib_dep,
libuv,
luajit,
lmdb,
libknot,
libdnssec,
......
......@@ -10,7 +10,7 @@ libkres_soversion = 9
modules_dir = join_paths(get_option('libdir'), 'kdns_modules')
# Dependencies
# Project-wide dependencies
knot_version = '>=2.7.6'
libknot = dependency('libknot', version: knot_version)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment