Commit 3eec662e authored by Vladimír Čunát's avatar Vladimír Čunát

module loading nitpick: improve error message

This should have been a part of 176b1c28, but I forgot it somehow.
parent 12c307e4
......@@ -98,7 +98,9 @@ static int load_sym_c(struct kr_module *module, uint32_t api_required)
|| load_symbol(module->lib, m_prefix, "props")) {
/* In case someone re-compiled against new kresd
* but haven't actually changed the symbols. */
kr_log_error("[system] module %s needs to change API.\n", module->name);
kr_log_error("[system] module %s requires upgrade. Please refer to "
"https://knot-resolver.readthedocs.io/en/stable/upgrading.hml",
module->name);
return kr_error(ENOTSUP);
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment