Commit b19fe04e authored by Michal Čihař's avatar Michal Čihař

Upgrade setuptools to avoid error when installing modules with environmnent markers

Several dependencies (eg. cryptography) use environment markers to
define dependencies based on Python version. This is not supported in
older setuptools and installation of modules then fails.
parent c0363816
......@@ -22,6 +22,9 @@ all:
prepare-dev:
@# lib*-dev and cffi for building cryptography, dependency of twisted.
apt-get install -y python python-dev python-pip python3 python3-dev python3-pip sshpass libffi-dev libssl-dev
# Upgrade setuptools and pip to avoid error when installing modules with environmnent markers
python2 -m pip install -U setuptools pip
python3 -m pip install -U setuptools pip
python2 -m pip install -U cffi
python3 -m pip install -U cffi
python2 -m pip install -e .[test]
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment